Awestruct and the v8-gate

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Awestruct and the v8-gate

Emmanuel Bernard
Hey guys,
So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
be installed on the system even for a regular user (ie not a
contributor).

This is a bit of a shame and also excludes all the poor souls lost in
Windows land.

Is there a plan to solve this problem? Can I help?

I am asking because with the `encoding: UTF-8` trick, I finally can use
0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
limitaiton is still problematic.

Emmanuel

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

LightGuard
Administrator
Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.

Sent from my iPhone

On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:

> Hey guys,
> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
> be installed on the system even for a regular user (ie not a
> contributor).
>
> This is a bit of a shame and also excludes all the poor souls lost in
> Windows land.
>
> Is there a plan to solve this problem? Can I help?
>
> I am asking because with the `encoding: UTF-8` trick, I finally can use
> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
> limitaiton is still problematic.
>
> Emmanuel
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

Lance Ball
All of these ongoing dependency issues are starting to become (or likely already are) a huge headache.

I'm advocating a 0.5 release as soon as is reasonable which uses tilt and leaves dependency management and lazy loading to the tilt gem.

LB

On Jan 14, 2013, at 9:38 AM, Jason Porter <[hidden email]> wrote:

> Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.
>
> Sent from my iPhone
>
> On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:
>
>> Hey guys,
>> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
>> be installed on the system even for a regular user (ie not a
>> contributor).
>>
>> This is a bit of a shame and also excludes all the poor souls lost in
>> Windows land.
>>
>> Is there a plan to solve this problem? Can I help?
>>
>> I am asking because with the `encoding: UTF-8` trick, I finally can use
>> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
>> limitaiton is still problematic.
>>
>> Emmanuel
>>
>> ---------------------------------------------------------------------
>> Archives: http://talk-archive.awestruct.org/
>> To unsubscribe, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>


---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

Emmanuel Bernard
In reply to this post by LightGuard
I have a Mac OS X 10.7 without v8 installed and I can get 0.4.7 running.
Maybe Windows has more problems but I'm not aware of them.

Emmanuel

On Mon 2013-01-14  7:38, Jason Porter wrote:

> Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.
>
> Sent from my iPhone
>
> On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:
>
> > Hey guys,
> > So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
> > be installed on the system even for a regular user (ie not a
> > contributor).
> >
> > This is a bit of a shame and also excludes all the poor souls lost in
> > Windows land.
> >
> > Is there a plan to solve this problem? Can I help?
> >
> > I am asking because with the `encoding: UTF-8` trick, I finally can use
> > 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
> > limitaiton is still problematic.
> >
> > Emmanuel
> >
> > ---------------------------------------------------------------------
> > Archives: http://talk-archive.awestruct.org/
> > To unsubscribe, e-mail: [hidden email]
> >
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

LightGuard
Administrator
In reply to this post by Lance Ball
A very big +1

Sent from my iPhone

On Jan 14, 2013, at 7:40, Lance Ball <[hidden email]> wrote:

> All of these ongoing dependency issues are starting to become (or likely already are) a huge headache.
>
> I'm advocating a 0.5 release as soon as is reasonable which uses tilt and leaves dependency management and lazy loading to the tilt gem.
>
> LB
>
> On Jan 14, 2013, at 9:38 AM, Jason Porter <[hidden email]> wrote:
>
>> Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.
>>
>> Sent from my iPhone
>>
>> On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:
>>
>>> Hey guys,
>>> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
>>> be installed on the system even for a regular user (ie not a
>>> contributor).
>>>
>>> This is a bit of a shame and also excludes all the poor souls lost in
>>> Windows land.
>>>
>>> Is there a plan to solve this problem? Can I help?
>>>
>>> I am asking because with the `encoding: UTF-8` trick, I finally can use
>>> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
>>> limitaiton is still problematic.
>>>
>>> Emmanuel
>>>
>>> ---------------------------------------------------------------------
>>> Archives: http://talk-archive.awestruct.org/
>>> To unsubscribe, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> Archives: http://talk-archive.awestruct.org/
>> To unsubscribe, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

mojavelinux

+1

A great way to ring in the New Year. Let's do it.

-Dan

--
Sent from my CyanogenMod-powered
Android device, an open platform for
carriers, developers and consumers.

On Jan 14, 2013 8:10 AM, "Jason Porter" <[hidden email]> wrote:
A very big +1

Sent from my iPhone

On Jan 14, 2013, at 7:40, Lance Ball <[hidden email]> wrote:

> All of these ongoing dependency issues are starting to become (or likely already are) a huge headache.
>
> I'm advocating a 0.5 release as soon as is reasonable which uses tilt and leaves dependency management and lazy loading to the tilt gem.
>
> LB
>
> On Jan 14, 2013, at 9:38 AM, Jason Porter <[hidden email]> wrote:
>
>> Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.
>>
>> Sent from my iPhone
>>
>> On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:
>>
>>> Hey guys,
>>> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
>>> be installed on the system even for a regular user (ie not a
>>> contributor).
>>>
>>> This is a bit of a shame and also excludes all the poor souls lost in
>>> Windows land.
>>>
>>> Is there a plan to solve this problem? Can I help?
>>>
>>> I am asking because with the `encoding: UTF-8` trick, I finally can use
>>> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
>>> limitaiton is still problematic.
>>>
>>> Emmanuel
>>>
>>> ---------------------------------------------------------------------
>>> Archives: http://talk-archive.awestruct.org/
>>> To unsubscribe, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> Archives: http://talk-archive.awestruct.org/
>> To unsubscribe, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

Torsten Curdt
+1


On Mon, Jan 14, 2013 at 4:21 PM, Dan Allen <[hidden email]> wrote:

+1

A great way to ring in the New Year. Let's do it.

-Dan

--
Sent from my CyanogenMod-powered
Android device, an open platform for
carriers, developers and consumers.

On Jan 14, 2013 8:10 AM, "Jason Porter" <[hidden email]> wrote:
A very big +1

Sent from my iPhone

On Jan 14, 2013, at 7:40, Lance Ball <[hidden email]> wrote:

> All of these ongoing dependency issues are starting to become (or likely already are) a huge headache.
>
> I'm advocating a 0.5 release as soon as is reasonable which uses tilt and leaves dependency management and lazy loading to the tilt gem.
>
> LB
>
> On Jan 14, 2013, at 9:38 AM, Jason Porter <[hidden email]> wrote:
>
>> Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.
>>
>> Sent from my iPhone
>>
>> On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:
>>
>>> Hey guys,
>>> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
>>> be installed on the system even for a regular user (ie not a
>>> contributor).
>>>
>>> This is a bit of a shame and also excludes all the poor souls lost in
>>> Windows land.
>>>
>>> Is there a plan to solve this problem? Can I help?
>>>
>>> I am asking because with the `encoding: UTF-8` trick, I finally can use
>>> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
>>> limitaiton is still problematic.
>>>
>>> Emmanuel
>>>
>>> ---------------------------------------------------------------------
>>> Archives: http://talk-archive.awestruct.org/
>>> To unsubscribe, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> Archives: http://talk-archive.awestruct.org/
>> To unsubscribe, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

LightGuard
Administrator
Has anyone started this in a branch?

Sent from my iPhone

On Jan 14, 2013, at 8:24, Torsten Curdt <[hidden email]> wrote:

+1


On Mon, Jan 14, 2013 at 4:21 PM, Dan Allen <[hidden email]> wrote:

+1

A great way to ring in the New Year. Let's do it.

-Dan

--
Sent from my CyanogenMod-powered
Android device, an open platform for
carriers, developers and consumers.

On Jan 14, 2013 8:10 AM, "Jason Porter" <[hidden email]> wrote:
A very big +1

Sent from my iPhone

On Jan 14, 2013, at 7:40, Lance Ball <[hidden email]> wrote:

> All of these ongoing dependency issues are starting to become (or likely already are) a huge headache.
>
> I'm advocating a 0.5 release as soon as is reasonable which uses tilt and leaves dependency management and lazy loading to the tilt gem.
>
> LB
>
> On Jan 14, 2013, at 9:38 AM, Jason Porter <[hidden email]> wrote:
>
>> Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.
>>
>> Sent from my iPhone
>>
>> On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:
>>
>>> Hey guys,
>>> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
>>> be installed on the system even for a regular user (ie not a
>>> contributor).
>>>
>>> This is a bit of a shame and also excludes all the poor souls lost in
>>> Windows land.
>>>
>>> Is there a plan to solve this problem? Can I help?
>>>
>>> I am asking because with the `encoding: UTF-8` trick, I finally can use
>>> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
>>> limitaiton is still problematic.
>>>
>>> Emmanuel
>>>
>>> ---------------------------------------------------------------------
>>> Archives: http://talk-archive.awestruct.org/
>>> To unsubscribe, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> Archives: http://talk-archive.awestruct.org/
>> To unsubscribe, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

Lance Ball
I know @qmx did some work on this - and I *think* @mojavelinux may have as well. But both of those were a while ago, and probably do not have most of the latest changes...

Lance

On Jan 14, 2013, at 10:27 AM, Jason Porter <[hidden email]> wrote:

Has anyone started this in a branch?

Sent from my iPhone

On Jan 14, 2013, at 8:24, Torsten Curdt <[hidden email]> wrote:

+1


On Mon, Jan 14, 2013 at 4:21 PM, Dan Allen <[hidden email]> wrote:

+1

A great way to ring in the New Year. Let's do it.

-Dan

--
Sent from my CyanogenMod-powered
Android device, an open platform for
carriers, developers and consumers.

On Jan 14, 2013 8:10 AM, "Jason Porter" <[hidden email]> wrote:
A very big +1

Sent from my iPhone

On Jan 14, 2013, at 7:40, Lance Ball <[hidden email]> wrote:

> All of these ongoing dependency issues are starting to become (or likely already are) a huge headache.
>
> I'm advocating a 0.5 release as soon as is reasonable which uses tilt and leaves dependency management and lazy loading to the tilt gem.
>
> LB
>
> On Jan 14, 2013, at 9:38 AM, Jason Porter <[hidden email]> wrote:
>
>> Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.
>>
>> Sent from my iPhone
>>
>> On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:
>>
>>> Hey guys,
>>> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
>>> be installed on the system even for a regular user (ie not a
>>> contributor).
>>>
>>> This is a bit of a shame and also excludes all the poor souls lost in
>>> Windows land.
>>>
>>> Is there a plan to solve this problem? Can I help?
>>>
>>> I am asking because with the `encoding: UTF-8` trick, I finally can use
>>> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
>>> limitaiton is still problematic.
>>>
>>> Emmanuel
>>>
>>> ---------------------------------------------------------------------
>>> Archives: http://talk-archive.awestruct.org/
>>> To unsubscribe, e-mail: [hidden email]
>>>
>>
>> ---------------------------------------------------------------------
>> Archives: http://talk-archive.awestruct.org/
>> To unsubscribe, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]



Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

cody.lerum
In reply to this post by LightGuard
0.4.7 worked fine for users and developers in Windows (they could build sites and build the source)

0.4.8 is broken for both in Windows.


On Mon, Jan 14, 2013 at 7:38 AM, Jason Porter <[hidden email]> wrote:
Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.

Sent from my iPhone

On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:

> Hey guys,
> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
> be installed on the system even for a regular user (ie not a
> contributor).
>
> This is a bit of a shame and also excludes all the poor souls lost in
> Windows land.
>
> Is there a plan to solve this problem? Can I help?
>
> I am asking because with the `encoding: UTF-8` trick, I finally can use
> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
> limitaiton is still problematic.
>
> Emmanuel
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Awestruct and the v8-gate

LightGuard
Administrator
Okay. We'll get it fixed in 0.5, hopefully it won't take long. 

Sent from my iPhone

On Jan 14, 2013, at 8:53, Cody Lerum <[hidden email]> wrote:

0.4.7 worked fine for users and developers in Windows (they could build sites and build the source)

0.4.8 is broken for both in Windows.


On Mon, Jan 14, 2013 at 7:38 AM, Jason Porter <[hidden email]> wrote:
Really?? Gah. You were able to install 0.4.7 on Windows? We were pretty sure it had the same issue (as reported by others). We're going to be looking very hard at cross-platform compatibility for the next release. We know its pretty bad right now.

Sent from my iPhone

On Jan 14, 2013, at 6:29, Emmanuel Bernard <[hidden email]> wrote:

> Hey guys,
> So apparently, starting from 0.4.8, Awestruct by ricochet requires v8 to
> be installed on the system even for a regular user (ie not a
> contributor).
>
> This is a bit of a shame and also excludes all the poor souls lost in
> Windows land.
>
> Is there a plan to solve this problem? Can I help?
>
> I am asking because with the `encoding: UTF-8` trick, I finally can use
> 0.4.7 for ceylon-lang.org and not get stoned by the team. But the v8
> limitaiton is still problematic.
>
> Emmanuel
>
> ---------------------------------------------------------------------
> Archives: http://talk-archive.awestruct.org/
> To unsubscribe, e-mail: [hidden email]
>

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]