Conflicting tilt versions

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Conflicting tilt versions

Gunnar Morling
Hi all,

I've just installed awestruct 0.5.1 on OS X (10.7.5). The installation didn't show any warnings or errors, but running awestruct afterwards causes the following error:

$ awestruct
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:230:in `activate': can't activate tilt (~> 1.3.6, runtime) for ["awestruct-0.5.1"], already activated tilt-1.4.1 for ["haml-4.0.2", "awestruct-0.5.1"] (Gem::LoadError)
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:246:in `activate'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:245:in `each'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:245:in `activate'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
from /usr/bin/awestruct:18

I'm no expert on gems, it seems to me as if different versions of the gem "tilt" are imported. Does anyone have an idea what's causing this issue and how it can be circumvented?

Thanks a lot,

--Gunnar