Quantcast

Not Web Server when upgrading to awsestruct 0.5.6.beta8

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Not Web Server when upgrading to awsestruct 0.5.6.beta8

xcoulon
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc.
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ?
Thanks !
Best regards,
Xavier
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

LightGuard
Administrator
Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc.
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ?
Thanks !
Best regards,
Xavier

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


--

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

xcoulon
It's explicitly set in the Gemfile that comes after 'awestruct -i'
Now, if I remove it from Gemfile and run 'rake update' again, then it's even worse: all I have in the terminal is:

$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...

and the command stops.

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 14:17, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;node=555&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc.
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ?
Thanks !
Best regards,
Xavier

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


--




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p555.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

LightGuard
Administrator
Huh. That's even more strange. You could try a different server, but webrick should just work. 

On Tuesday, March 17, 2015, xcoulon <[hidden email]> wrote:
It's explicitly set in the Gemfile that comes after 'awestruct -i'
Now, if I remove it from Gemfile and run 'rake update' again, then it's even worse: all I have in the terminal is:

$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...

and the command stops.

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 14:17, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;node=555&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc.
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ?
Thanks !
Best regards,
Xavier

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


--




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p555.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML



View this message in context: Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


--

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

xcoulon
Just curious: can you reproduce the same behaviour on your machine ? Or is it something related to my config/environment/setup ? (I'm using RVM, too)

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 17:49, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Huh. That's even more strange. You could try a different server, but webrick should just work. 

On Tuesday, March 17, 2015, xcoulon <<a href="x-msg://77/user/SendEmail.jtp?type=node&amp;node=557&amp;i=0" target="_top" rel="nofollow" link="external" style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;" class="">[hidden email]> wrote:
It's explicitly set in the Gemfile that comes after 'awestruct -i'
Now, if I remove it from Gemfile and run 'rake update' again, then it's even worse: all I have in the terminal is:

$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...

and the command stops.

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 14:17, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;node=555&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc. 
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ? 
Thanks ! 
Best regards, 
Xavier 

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


-- 




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p555.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML



View this message in context: Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


-- 




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p557.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

LightGuard
Administrator
I've never seen it on my machine, do you have things up somewhere I can download it?

On Tue, Mar 17, 2015 at 2:31 PM, xcoulon <[hidden email]> wrote:
Just curious: can you reproduce the same behaviour on your machine ? Or is it something related to my config/environment/setup ? (I'm using RVM, too)

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 17:49, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Huh. That's even more strange. You could try a different server, but webrick should just work. 

On Tuesday, March 17, 2015, xcoulon <<a href="x-msg://77/user/SendEmail.jtp?type=node&amp;node=557&amp;i=0" target="_top" rel="nofollow" link="external" style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;" class="">[hidden email]> wrote:
It's explicitly set in the Gemfile that comes after 'awestruct -i'
Now, if I remove it from Gemfile and run 'rake update' again, then it's even worse: all I have in the terminal is:

$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...

and the command stops.

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 14:17, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;node=555&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc. 
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ? 
Thanks ! 
Best regards, 
Xavier 

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


-- 




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p555.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p557.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML




--
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

xcoulon
I just published the files on GitHub: https://github.com/xcoulon/sample-awestruct-website

Please let me know if you find something weird/incorrect there.

Thanks !
Best regards,
/Xavier



On 18 Mar 2015, at 00:26, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

I've never seen it on my machine, do you have things up somewhere I can download it?

On Tue, Mar 17, 2015 at 2:31 PM, xcoulon <<a href="x-msg://92/user/SendEmail.jtp?type=node&amp;node=559&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Just curious: can you reproduce the same behaviour on your machine ? Or is it something related to my config/environment/setup ? (I'm using RVM, too)

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 17:49, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Huh. That's even more strange. You could try a different server, but webrick should just work. 

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="x-msg://77/user/SendEmail.jtp?type=node&amp;amp;node=557&amp;amp;i=0" class="">x-msg://77/user/SendEmail.jtp?type=node&amp;node=557&amp;i=0" target="_top" rel="nofollow" link="external" style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;" class="">[hidden email]> wrote:
It's explicitly set in the Gemfile that comes after 'awestruct -i'
Now, if I remove it from Gemfile and run 'rake update' again, then it's even worse: all I have in the terminal is:

$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...

and the command stops.

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 14:17, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;amp;node=555&amp;amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class=""><a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;node=555&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc. 
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ? 
Thanks ! 
Best regards, 
Xavier 

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


-- 




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p555.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p557.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML




-- 



If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p559.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

LightGuard
Administrator
Here's the patch, I need to fix it in awestruct. LiveReload is causing issues because it doesn't see anything and the thread doesn't spawn or something and it shuts everything down.

diff --git a/Rakefile b/Rakefile
index 0230c03..c27b03a 100644
--- a/Rakefile
+++ b/Rakefile
@@ -92,7 +92,7 @@ end
 
 desc 'Build and preview the site locally in development mode'
 task :preview => :check do
-  run_awestruct '-d'
+  run_awestruct '-d --no-livereload'
 end
 
 # provide a serve task for those used to Jekyll commands


On Wed, Mar 18, 2015 at 8:46 AM, xcoulon <[hidden email]> wrote:
I just published the files on GitHub: https://github.com/xcoulon/sample-awestruct-website

Please let me know if you find something weird/incorrect there.

Thanks !
Best regards,
/Xavier



On 18 Mar 2015, at 00:26, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

I've never seen it on my machine, do you have things up somewhere I can download it?

On Tue, Mar 17, 2015 at 2:31 PM, xcoulon <<a href="x-msg://92/user/SendEmail.jtp?type=node&amp;node=559&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Just curious: can you reproduce the same behaviour on your machine ? Or is it something related to my config/environment/setup ? (I'm using RVM, too)

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 17:49, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Huh. That's even more strange. You could try a different server, but webrick should just work. 

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="x-msg://77/user/SendEmail.jtp?type=node&amp;amp;node=557&amp;amp;i=0" class="">x-msg://77/user/SendEmail.jtp?type=node&amp;node=557&amp;i=0" target="_top" rel="nofollow" link="external" style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;" class="">[hidden email]> wrote:
It's explicitly set in the Gemfile that comes after 'awestruct -i'
Now, if I remove it from Gemfile and run 'rake update' again, then it's even worse: all I have in the terminal is:

$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...

and the command stops.

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 14:17, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;amp;node=555&amp;amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class=""><a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;node=555&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc. 
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ? 
Thanks ! 
Best regards, 
Xavier 

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


-- 




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p555.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p557.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p559.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML




--
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not Web Server when upgrading to awsestruct 0.5.6.beta8

xcoulon
Awesome !
I confirm it works here too \o/

Thanks a lot, Jason !

Best regards,
/Xavier



On 19 Mar 2015, at 02:38, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Here's the patch, I need to fix it in awestruct. LiveReload is causing issues because it doesn't see anything and the thread doesn't spawn or something and it shuts everything down.

diff --git a/Rakefile b/Rakefile
index 0230c03..c27b03a 100644
--- a/Rakefile
+++ b/Rakefile
@@ -92,7 +92,7 @@ end
 
 desc 'Build and preview the site locally in development mode'
 task :preview => :check do
-  run_awestruct '-d'
+  run_awestruct '-d --no-livereload'
 end
 
 # provide a serve task for those used to Jekyll commands


On Wed, Mar 18, 2015 at 8:46 AM, xcoulon <<a href="x-msg://94/user/SendEmail.jtp?type=node&amp;node=561&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
I just published the files on GitHub: https://github.com/xcoulon/sample-awestruct-website

Please let me know if you find something weird/incorrect there.

Thanks !
Best regards,
/Xavier



On 18 Mar 2015, at 00:26, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

I've never seen it on my machine, do you have things up somewhere I can download it?

On Tue, Mar 17, 2015 at 2:31 PM, xcoulon <<a href="<a href="x-msg://92/user/SendEmail.jtp?type=node&amp;amp;node=559&amp;amp;i=0" class="">x-msg://92/user/SendEmail.jtp?type=node&amp;node=559&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Just curious: can you reproduce the same behaviour on your machine ? Or is it something related to my config/environment/setup ? (I'm using RVM, too)

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 17:49, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Huh. That's even more strange. You could try a different server, but webrick should just work. 

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="<a href="x-msg://77/user/SendEmail.jtp?type=node&amp;amp;amp;node=557&amp;amp;amp;i=0" class="">x-msg://77/user/SendEmail.jtp?type=node&amp;amp;node=557&amp;amp;i=0" class=""><a href="x-msg://77/user/SendEmail.jtp?type=node&amp;amp;node=557&amp;amp;i=0" class="">x-msg://77/user/SendEmail.jtp?type=node&amp;node=557&amp;i=0" target="_top" rel="nofollow" link="external" style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;" class="">[hidden email]> wrote:
It's explicitly set in the Gemfile that comes after 'awestruct -i'
Now, if I remove it from Gemfile and run 'rake update' again, then it's even worse: all I have in the terminal is:

$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...

and the command stops.

Thanks
Best regards,
/Xavier



On 17 Mar 2015, at 14:17, LightGuard [via Awestruct Talk] <[hidden email]> wrote:

Never seen that. Webrick is part of ruby, you shouldn't need it as a dependency

On Tuesday, March 17, 2015, xcoulon <<a href="<a href="<a href="<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;amp;amp;node=555&amp;amp;amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;amp;amp;node=555&amp;amp;amp;i=0" class=""><a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;amp;node=555&amp;amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class=""><a href="<a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;amp;node=555&amp;amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class=""><a href="x-msg://70/user/SendEmail.jtp?type=node&amp;amp;node=555&amp;amp;i=0" class="">x-msg://70/user/SendEmail.jtp?type=node&amp;node=555&amp;i=0" target="_top" rel="nofollow" link="external" class="">[hidden email]> wrote:
Hello, I'm starting a new static web site project from scratch (using ruby 2.0.0) and here's what I do:
$> gem install awestruct -v 0.5.6.beta8
$> awestruct -version
Awestruct: 0.5.6.beta8
http://awestruct.org/
$> awestruct -i
This creates the project skeleton with a base template, etc. 
$> rake preview
Running command: bundle exec awestruct -d
...

***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
[2015-03-17 09:09:14] INFO  WEBrick 1.3.1
[2015-03-17 09:09:14] INFO  ruby 2.0.0 (2014-02-24) [x86_64-darwin12.5.0]
[2015-03-17 09:09:14] INFO  WEBrick::HTTPServer#start: pid=26243 port=4242
Now, I update the gem dependencies in Gemfile to:
	source 'https://rubygems.org'                             # This tells Bundler where to look for gems
	gem 'awestruct', '~> 0.5.6.beta8'                               # Goes without saying
	gem 'webrick', '~> 1.3.1'                                 # The rack webserver to use in dev mode
$> rake update
Fetching gem metadata from https://rubygems.org/........
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Using asciidoctor (1.5.2)
Using sass (3.4.13)
Using bootstrap-sass (3.2.0.2)
Using colorize (0.7.5)
Using chunky_png (1.3.4)
Using multi_json (1.11.0)
Using compass-core (1.0.3)
Using compass-import-once (1.0.5)
Using rb-fsevent (0.9.4)
Using ffi (1.9.8)
Using rb-inotify (0.9.5)
Using compass (1.0.3)
Using compass-960-plugin (0.10.4)
Using git (1.2.9.1)
Using eventmachine (1.0.7)
Using http_parser.rb (0.6.0)
Using em-websocket (0.5.1)
Using formatador (0.2.5)
Using hitimes (1.2.2)
Using timers (4.0.1)
Using celluloid (0.16.0)
Using listen (2.7.12)
Using lumberjack (1.0.9)
Using nenv (0.2.0)
Using shellany (0.0.1)
Using notiffany (0.0.6)
Using coderay (1.1.0)
Using method_source (0.8.2)
Using slop (3.6.0)
Using pry (0.10.1)
Using thor (0.19.1)
Using guard (2.12.5)
Using guard-livereload (2.1.3)
Using tilt (2.0.1)
Using haml (4.0.6)
Using mime-types (2.4.3)
Using parallel (1.4.1)
Using rack (1.5.2)
Using netrc (0.10.3)
Using rest-client (1.7.3)
Using ruby-s3cmd (0.1.5)
Using zurb-foundation (4.3.2)
Using awestruct (0.5.6.beta8)
Using webrick (1.3.1)
Using bundler (1.5.3)
Your bundle is updated!
and when I want to preview the site again:
$> rake preview
Running command: bundle exec awestruct -d
Generating site: http://localhost:4242
Excecuting pipeline...
Generating pages...
***************************************************************************
Starting preview server at http://localhost:4242 (Press Ctrl-C to shutdown)
***************************************************************************
there's no WEBrick server running, the command just exited. I wonder if there's a dependency mismatch or missing after the gem version upgrade, but I can't see anything. Do you have any idea ? 
Thanks ! 
Best regards, 
Xavier 

View this message in context: Not Web Server when upgrading to awsestruct 0.5.6.beta8
Sent from the Awestruct Talk mailing list archive at Nabble.com.


-- 




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p555.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p557.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML




If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p559.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML




--



If you reply to this email, your message will be added to the discussion below:
http://talk-archive.awestruct.org/Not-Web-Server-when-upgrading-to-awsestruct-0-5-6-beta8-tp554p561.html
To unsubscribe from Not Web Server when upgrading to awsestruct 0.5.6.beta8, click here.
NAML

Loading...