Page title of posts not set

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Page title of posts not set

Christian Grobmeier
Hi all,

I am trying awestruct and got started pretty quickly, but failed with
a trivial thing.

I use that:
http://awestruct.org/extensions/posts/

I simply copy/pasted the example and made use of the .posts object to
output all titles as clickable link. The link appears, but the title
is not there.

Then I modified my page to:

---
title: My fancy page
author: Bob McWhirter
layout: base
---

#{page}


I was expecting that the title is printed with #{page}. But there is
no title property. When I remove "title:" nothing changes.

Thats my file name:
2013-01-04-another-post.md

It seems its rendered to the correct place, just the page.title
property is not available.

Anything I miss?

Cheers,
Christian

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Page title of posts not set

Torsten Curdt
Did you use post.title or page.title?
Reply | Threaded
Open this post in threaded view
|

Re: Page title of posts not set

Christian Grobmeier
I used that (from the docs):

- for post in site.posts
  .post
    %h2
      %a{:href=>post.url}= post.title
    %strong= post.date.strftime( '%d %B %Y' )
    .content
      = post.content


When i output:
#{site}

I cannot find the title too

On Wed, Jan 2, 2013 at 8:52 PM, Torsten Curdt <[hidden email]> wrote:
> Did you use post.title or page.title?



--
http://www.grobmeier.de
https://www.timeandbill.de

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Page title of posts not set

Torsten Curdt
site.title is a different topic.
site.posts should be available as soon as you enable the extension in the pipeline.

There are a couple of live sites around where could also have a look.


cheers,
Torsten

PS: feel free to catch me on skype to shorten the back and forth writing ;)
Reply | Threaded
Open this post in threaded view
|

Re: Page title of posts not set

Christian Grobmeier
For some reason a restart of my mac helped. Not sure what I made
wrong, but it looks ways better now.
Well, I can't output the title on the specific page itself; its not
really that I need it, I am just confused by it. No need to discuss
this further, I guess I will need to checkout awestruct sources.

My overall feeling with awestruct is pretty good. It feels so "clean"
and "easy", compared to others. On the other hand, I have missed some
docs. For example, what frameworks (besides Bootstrap) are supported?

While we are at it, starting a new project with awestruct is just fun.
Besides I like the "pipeline".

Cheers
Christian

On Thu, Jan 3, 2013 at 1:49 AM, Torsten Curdt <[hidden email]> wrote:

> site.title is a different topic.
> site.posts should be available as soon as you enable the extension in the
> pipeline.
>
> There are a couple of live sites around where could also have a look.
>
>  http://awestruct.org/gallery/
>
> cheers,
> Torsten
>
> PS: feel free to catch me on skype to shorten the back and forth writing ;)



--
http://www.grobmeier.de
https://www.timeandbill.de

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]