Tag filtering not configured properly ?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Tag filtering not configured properly ?

Olivier Catteau
Hi,

I'm trying to migrate my Wordpress blog to Awestruct but I have a problem with tags. I suppose that it's a problem of configuration.
In fact, I have a few blog posts with tags. The tag cloud is correctly generated with the different tags. But when I click on a tag there is no filtering, the generated page contains all posts without taking in account the selected tag.

My pipeline.rb is the following :

Awestruct::Extensions::Pipeline.new do
  extension Awestruct::Extensions::Posts.new( '/blog', :posts )
  extension Awestruct::Extensions::Paginator.new( :posts, '/blog/index', :per_page=>5 )
  extension Awestruct::Extensions::Tagger.new( :posts, '/blog/index', '/blog/tags', :per_page=>5)
  extension Awestruct::Extensions::TagCloud.new(:posts, '/blog/tags/index.html', :layout=>'blog', :title=>'Tags') 
  extension Awestruct::Extensions::Indexifier.new
  extension Awestruct::Extensions::Flattr.new
  extension Awestruct::Extensions::Disqus.new
  helper Awestruct::Extensions::Partial
  helper Awestruct::Extensions::GoogleAnalytics
end

Could you help me ?

Thanks !
Olivier
Reply | Threaded
Open this post in threaded view
|

Re: Tag filtering not configured properly ?

LightGuard
Administrator


On Fri, May 10, 2013 at 4:15 AM, Olivier Catteau <[hidden email]> wrote:
Hi,

I'm trying to migrate my Wordpress blog to Awestruct but I have a problem with tags. I suppose that it's a problem of configuration.
In fact, I have a few blog posts with tags. The tag cloud is correctly generated with the different tags. But when I click on a tag there is no filtering, the generated page contains all posts without taking in account the selected tag.

My pipeline.rb is the following :

Awestruct::Extensions::Pipeline.new do
  extension Awestruct::Extensions::Posts.new( '/blog', :posts )
  extension Awestruct::Extensions::Paginator.new( :posts, '/blog/index', :per_page=>5 )
  extension Awestruct::Extensions::Tagger.new( :posts, '/blog/index', '/blog/tags', :per_page=>5)
  extension Awestruct::Extensions::TagCloud.new(:posts, '/blog/tags/index.html', :layout=>'blog', :title=>'Tags') 
  extension Awestruct::Extensions::Indexifier.new
  extension Awestruct::Extensions::Flattr.new
  extension Awestruct::Extensions::Disqus.new
  helper Awestruct::Extensions::Partial
  helper Awestruct::Extensions::GoogleAnalytics
end

Could you help me ?

Thanks !
Olivier



--
Reply | Threaded
Open this post in threaded view
|

Re: Tag filtering not configured properly ?

Olivier Catteau
Thanks Jason. I had a look to your github and also to https://github.com/emmanuelbernard/emmanuelbernard.com but I don't understand why the generation of the tagged pages doesn't work properly for my project.
I have published my project to github : https://github.com/ocatteau/stateofmind.fr.website 
Can anyone help me by having a look to my configuration ? 

Thanks !


2013/5/10 Jason Porter <[hidden email]>


On Fri, May 10, 2013 at 4:15 AM, Olivier Catteau <[hidden email]> wrote:
Hi,

I'm trying to migrate my Wordpress blog to Awestruct but I have a problem with tags. I suppose that it's a problem of configuration.
In fact, I have a few blog posts with tags. The tag cloud is correctly generated with the different tags. But when I click on a tag there is no filtering, the generated page contains all posts without taking in account the selected tag.

My pipeline.rb is the following :

Awestruct::Extensions::Pipeline.new do
  extension Awestruct::Extensions::Posts.new( '/blog', :posts )
  extension Awestruct::Extensions::Paginator.new( :posts, '/blog/index', :per_page=>5 )
  extension Awestruct::Extensions::Tagger.new( :posts, '/blog/index', '/blog/tags', :per_page=>5)
  extension Awestruct::Extensions::TagCloud.new(:posts, '/blog/tags/index.html', :layout=>'blog', :title=>'Tags') 
  extension Awestruct::Extensions::Indexifier.new
  extension Awestruct::Extensions::Flattr.new
  extension Awestruct::Extensions::Disqus.new
  helper Awestruct::Extensions::Partial
  helper Awestruct::Extensions::GoogleAnalytics
end

Could you help me ?

Thanks !
Olivier



--

Reply | Threaded
Open this post in threaded view
|

Re: Tag filtering not configured properly ?

LightGuard
Administrator
You're using a very old version of awestruct, have you tried with 0.5.1?


On Sat, May 11, 2013 at 6:38 AM, Olivier Catteau <[hidden email]> wrote:
Thanks Jason. I had a look to your github and also to https://github.com/emmanuelbernard/emmanuelbernard.com but I don't understand why the generation of the tagged pages doesn't work properly for my project.
I have published my project to github : https://github.com/ocatteau/stateofmind.fr.website 
Can anyone help me by having a look to my configuration ? 

Thanks !


2013/5/10 Jason Porter <[hidden email]>


On Fri, May 10, 2013 at 4:15 AM, Olivier Catteau <[hidden email]> wrote:
Hi,

I'm trying to migrate my Wordpress blog to Awestruct but I have a problem with tags. I suppose that it's a problem of configuration.
In fact, I have a few blog posts with tags. The tag cloud is correctly generated with the different tags. But when I click on a tag there is no filtering, the generated page contains all posts without taking in account the selected tag.

My pipeline.rb is the following :

Awestruct::Extensions::Pipeline.new do
  extension Awestruct::Extensions::Posts.new( '/blog', :posts )
  extension Awestruct::Extensions::Paginator.new( :posts, '/blog/index', :per_page=>5 )
  extension Awestruct::Extensions::Tagger.new( :posts, '/blog/index', '/blog/tags', :per_page=>5)
  extension Awestruct::Extensions::TagCloud.new(:posts, '/blog/tags/index.html', :layout=>'blog', :title=>'Tags') 
  extension Awestruct::Extensions::Indexifier.new
  extension Awestruct::Extensions::Flattr.new
  extension Awestruct::Extensions::Disqus.new
  helper Awestruct::Extensions::Partial
  helper Awestruct::Extensions::GoogleAnalytics
end

Could you help me ?

Thanks !
Olivier



--




--
Reply | Threaded
Open this post in threaded view
|

Re: Tag filtering not configured properly ?

Olivier Catteau
Ok thanks, now it works !


2013/5/29 Jason Porter <[hidden email]>
You're using a very old version of awestruct, have you tried with 0.5.1?


On Sat, May 11, 2013 at 6:38 AM, Olivier Catteau <[hidden email]> wrote:
Thanks Jason. I had a look to your github and also to https://github.com/emmanuelbernard/emmanuelbernard.com but I don't understand why the generation of the tagged pages doesn't work properly for my project.
I have published my project to github : https://github.com/ocatteau/stateofmind.fr.website 
Can anyone help me by having a look to my configuration ? 

Thanks !


2013/5/10 Jason Porter <[hidden email]>


On Fri, May 10, 2013 at 4:15 AM, Olivier Catteau <[hidden email]> wrote:
Hi,

I'm trying to migrate my Wordpress blog to Awestruct but I have a problem with tags. I suppose that it's a problem of configuration.
In fact, I have a few blog posts with tags. The tag cloud is correctly generated with the different tags. But when I click on a tag there is no filtering, the generated page contains all posts without taking in account the selected tag.

My pipeline.rb is the following :

Awestruct::Extensions::Pipeline.new do
  extension Awestruct::Extensions::Posts.new( '/blog', :posts )
  extension Awestruct::Extensions::Paginator.new( :posts, '/blog/index', :per_page=>5 )
  extension Awestruct::Extensions::Tagger.new( :posts, '/blog/index', '/blog/tags', :per_page=>5)
  extension Awestruct::Extensions::TagCloud.new(:posts, '/blog/tags/index.html', :layout=>'blog', :title=>'Tags') 
  extension Awestruct::Extensions::Indexifier.new
  extension Awestruct::Extensions::Flattr.new
  extension Awestruct::Extensions::Disqus.new
  helper Awestruct::Extensions::Partial
  helper Awestruct::Extensions::GoogleAnalytics
end

Could you help me ?

Thanks !
Olivier



--




--