Tilt changes somewhere around 0.5.4?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Tilt changes somewhere around 0.5.4?

Gerhard Poul
Hi,

When migrating my blog to the latest version I noticed that starting
with 0.5.4 and its dependencies I get some change in behavior that
causes the

    Tilt.prefer Tilt::MarukuTemplate

in _ext/pipeline.rb to fail with

    $ rake
    Generating site: http://localhost:4242
    While processing file
    An error occurred: uninitialized constant Awestruct::Tilt::MarukuTemplate
    /root/gpoul.strain.at/_ext/pipeline.rb:3:in `load_pipeline'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/engine.rb:223:in
`eval'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/engine.rb:223:in
`load_pipeline'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/engine.rb:65:in
`run'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/cli/generate.rb:21:in
`run'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/cli/invoker.rb:119:in
`invoke_generate'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/cli/invoker.rb:49:in
`invoke!'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/bin/awestruct:9:in
`<top (required)>'
    /usr/local/bin/awestruct:23:in `load'
    /usr/local/bin/awestruct:23:in `<main>'

has anyone seen this before? I think I missed something, but I wasn't
able to figure this out by googling on my own :-/

Thanks,
Gerhard

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tilt changes somewhere around 0.5.4?

LightGuard
Administrator
Yeah, we updated tilt versions. Create an issue please.


On Wed, Apr 16, 2014 at 11:46 AM, Gerhard Poul <[hidden email]> wrote:
Hi,

When migrating my blog to the latest version I noticed that starting
with 0.5.4 and its dependencies I get some change in behavior that
causes the

    Tilt.prefer Tilt::MarukuTemplate

in _ext/pipeline.rb to fail with

    $ rake
    Generating site: http://localhost:4242
    While processing file
    An error occurred: uninitialized constant Awestruct::Tilt::MarukuTemplate
    /root/gpoul.strain.at/_ext/pipeline.rb:3:in `load_pipeline'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/engine.rb:223:in
`eval'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/engine.rb:223:in
`load_pipeline'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/engine.rb:65:in
`run'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/cli/generate.rb:21:in
`run'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/cli/invoker.rb:119:in
`invoke_generate'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/lib/awestruct/cli/invoker.rb:49:in
`invoke!'
    /usr/local/share/gems/gems/awestruct-0.5.4.2/bin/awestruct:9:in
`<top (required)>'
    /usr/local/bin/awestruct:23:in `load'
    /usr/local/bin/awestruct:23:in `<main>'

has anyone seen this before? I think I missed something, but I wasn't
able to figure this out by googling on my own :-/

Thanks,
Gerhard

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]




--
Reply | Threaded
Open this post in threaded view
|

Re: Tilt changes somewhere around 0.5.4?

Gerhard Poul
On Wed, Apr 16, 2014 at 7:51 PM, Jason Porter <[hidden email]> wrote:
> Yeah, we updated tilt versions. Create an issue please.

done: https://github.com/awestruct/awestruct/issues/414

---------------------------------------------------------------------
Archives: http://talk-archive.awestruct.org/
To unsubscribe, e-mail: [hidden email]