awestruct with bundler

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

awestruct with bundler

LightGuard
Administrator
Here's the Gemfile I had to create to get awestruct -d to work on my blog (I'm not doing anything special), but I am using LESS


gem "awestruct"
gem "therubyracer", '~> 0.10.0'
gem "html_truncator"
gem 'rb-inotify', '~> 0.8.8'


looks like we're using things that aren't being called out as dependencies for awestruct.

--
Reply | Threaded
Open this post in threaded view
|

Re: awestruct with bundler

bobmcwhirter
Administrator
I'd say the rhino one is right since that's very platform specific. The others should maybe be in the awestruct gem spec. 



--
Sent from my iPhone


On Jan 18, 2013, at 10:49 PM, Jason Porter <[hidden email]> wrote:

Here's the Gemfile I had to create to get awestruct -d to work on my blog (I'm not doing anything special), but I am using LESS


gem "awestruct"
gem "therubyracer", '~> 0.10.0'
gem "html_truncator"
gem 'rb-inotify', '~> 0.8.8'


looks like we're using things that aren't being called out as dependencies for awestruct.

--
Reply | Threaded
Open this post in threaded view
|

Re: awestruct with bundler

bobmcwhirter
Administrator
Of course I mean the rubyracer/v8 is probably appropriate in your own gemfile. If you were using jruby then you'd need the rubyrhino. That's what I mean by platform-specific. 

Bob

--
Sent from my iPhone


On Jan 19, 2013, at 10:16 AM, Bob McWhirter <[hidden email]> wrote:

I'd say the rhino one is right since that's very platform specific. The others should maybe be in the awestruct gem spec. 



--
Sent from my iPhone


On Jan 18, 2013, at 10:49 PM, Jason Porter <[hidden email]> wrote:

Here's the Gemfile I had to create to get awestruct -d to work on my blog (I'm not doing anything special), but I am using LESS


gem "awestruct"
gem "therubyracer", '~> 0.10.0'
gem "html_truncator"
gem 'rb-inotify', '~> 0.8.8'


looks like we're using things that aren't being called out as dependencies for awestruct.

--
Reply | Threaded
Open this post in threaded view
|

Re: awestruct with bundler

LightGuard
Administrator
Correct, I understood :)

Sent from my iPhone

On Jan 19, 2013, at 8:17, Bob McWhirter <[hidden email]> wrote:

Of course I mean the rubyracer/v8 is probably appropriate in your own gemfile. If you were using jruby then you'd need the rubyrhino. That's what I mean by platform-specific. 

Bob

--
Sent from my iPhone


On Jan 19, 2013, at 10:16 AM, Bob McWhirter <[hidden email]> wrote:

I'd say the rhino one is right since that's very platform specific. The others should maybe be in the awestruct gem spec. 



--
Sent from my iPhone


On Jan 18, 2013, at 10:49 PM, Jason Porter <[hidden email]> wrote:

Here's the Gemfile I had to create to get awestruct -d to work on my blog (I'm not doing anything special), but I am using LESS


gem "awestruct"
gem "therubyracer", '~> 0.10.0'
gem "html_truncator"
gem 'rb-inotify', '~> 0.8.8'


looks like we're using things that aren't being called out as dependencies for awestruct.

--